This message will typically appear once you reach the login screen if you are using a browser that is too old to support SafetySkills training, usually a version of Internet Explorer prior to version 10.

This message will typically appear once you reach the login screen if you are using a browser that is too old to support SafetySkills training, usually a version of Internet Explorer prior to version 10. To resolve this issue, you will only need to upgrade your browser, or try utilizing a different browser, such as Google Chrome. Depending on your company’s security settings, you may need to reach out to your local IT Department for assistance in upgrading or changing browsers.

For a full list of our minimum and recommended settings to optimally run SafetySkills training, please click here. If you are experiencing an issue that is not listed here, please contact SafetySkills Customer Care by submitting a ticket through the red Support and Feedback tab, or by emailing support@safetyskills.com and include a screenshot of the error you are experiencing.